Note that some changes here have been postponed to some future release:
- random-generated auto-name has not been implemented. Hence you are still responsible for naming your models or modules. When duplicating a model for example, Jamoma will register it in the namespace using ithe provided name followed by a “.1” instance number.
- j.parameter remains j.parameter for now.
Here are some changes that we have decided on so far in the workshop:
Naming of model, view and module instances
We have decided that when a user creates a model, view or module and does not explicitly provide a name for the instance, we’ll add a unique (random-generated) name. This name will be consistent; that is it will be saved with the patch and recalled the next time the patch is opened. This will for instance resolve some problems that can be experienced when opening help patches for models, and experiencing that the models of the help patch ends up conflicting with the module names used in the users own patchers.
Reorganising inlets and outlets
Up until now we have reserved the leftmost inlet and outlet of models for OSC communication. This is about to change. In audio and video (Jitter) models we will now use the leftmost inlet for signals in the same way as for regular MSP and Jitter externals. OSC messages can also be passed to this inlet, so behaviour will become much more consistent with how regular externals behave. We will make AudioGraph externals behave similarly.
OSC messages returned from the model will be passed out from the rightmost outlet, in a similar way to the dumpout outlet of Jitter objects.
j.parameter will be renamed j.attribute
This change will make it much easier to document models using the Max refpage system. If the Max auto-completion system could be extended to serve abstraction with refpages in the same way as for externals, it would become tremendously useful, as our j.parameters could basically be considered attributes with added abilities.
AudioGraph externals for Max will be renamed
We will substitute the
≈ sign for
=. This makes life much easier for us when compiling for Windows, and also resolves the problem that many do not know how to type ≈ on their keyboards.
Graph externals for Max will be renamed
We will substitute the
# sign for
Surround sound models will be renamed
Rather than long and cumbersom names such as
sur.dbap.model, we’ll use
Naming convention: under_score rather than camelCase
The majority of developers feel that under_score is more readable than camelCase. In addition it seems to be more consistent with what other developers do in Max.
We also recommend that the first part of names should identify the context that the message is addressing, so that as little reading as possible is required to understand what this message is all about. As an example
speaker_count is preferable to
More to come!